Infrastructure issue affecting all Nabla services

Incident Report for Nabla

Resolved

Still no signs of any issue since the last update => closing this incident.
Posted Jun 12, 2025 - 21:46 UTC

Update

Our observability shows no signs of errors in the last 15 minutes: Nabla should be fully operational again.

We're keeping this incident open as we monitor the situation.
Posted Jun 12, 2025 - 20:40 UTC

Monitoring

Service is recovering, and now seems mostly healthy in all regions.
Posted Jun 12, 2025 - 20:30 UTC

Update

Service seems to have recovered in non-US regions. US remains down.
Posted Jun 12, 2025 - 20:08 UTC

Identified

GCP claims their incident is now fully recovered in all regions except US (https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW), however we don't find that to be the case.

All of Nabla's services continue to be down or very unstable at the moment.
Posted Jun 12, 2025 - 19:42 UTC

Update

The outage is still ongoing and affecting all Nabla services (especially US).

We apologize for the disruption and continue to monitor the situation and try to restore service.

However, in all likelihood we unfortunately cannot do anything substantial about this until GCP's outage is resolved.
Posted Jun 12, 2025 - 19:31 UTC

Update

The GCP incident is still ongoing, and continues affecting all of Nabla's services.
Posted Jun 12, 2025 - 19:08 UTC

Update

We have confirmed the root cause is GCP-related.

GCP is now showing the incident on their own status page: https://status.cloud.google.com/
Posted Jun 12, 2025 - 18:52 UTC

Investigating

We are currently investigating the issue. Initial data points to an outage of our cloud provider (Google).
Posted Jun 12, 2025 - 18:39 UTC
This incident affected: API and App.