Partial outage: async operations

Incident Report for Nabla

Resolved

(As explained in the message above, the situation resolved in under 10' with the end of our deployment).
Posted Sep 23, 2025 - 14:15 UTC

Identified

Our service suffered a partial outage for all async operations during our routine deployment today.

Start: 2025-09-23 15:47:41.939 UTC+2
End: 2025-09-23 15:56:09.602 UTC+2

During that time, all endpoints starting async operations (like a note generation) had a chance to immediately fail with an HTTP 500.

Root cause: accidental breaking change.
Posted Sep 23, 2025 - 14:14 UTC
This incident affected: API and App.